Manifests.io

Easy to use kubernetes documentation

PersistentVolume.spec

PersistentVolumeSpec is the specification of a persistent volume.

Description
accessModes
array

accessModes contains all ways the volume can be mounted. More info: https://kubernetes.io/docs/concepts/storage/persistent-volumes#access-modes

awsElasticBlockStore 🔗
AWSElasticBlockStoreVolumeSource

awsElasticBlockStore represents an AWS Disk resource that is attached to a kubelet's host machine and then exposed to the pod. More info: https://kubernetes.io/docs/concepts/storage/volumes#awselasticblockstore

azureDisk 🔗
AzureDiskVolumeSource

azureDisk represents an Azure Data Disk mount on the host and bind mount to the pod.

azureFile 🔗
AzureFilePersistentVolumeSource

azureFile represents an Azure File Service mount on the host and bind mount to the pod.

capacity
object

capacity is the description of the persistent volume's resources and capacity. More info: https://kubernetes.io/docs/concepts/storage/persistent-volumes#capacity

cephfs 🔗
CephFSPersistentVolumeSource

cephFS represents a Ceph FS mount on the host that shares a pod's lifetime

cinder 🔗
CinderPersistentVolumeSource

cinder represents a cinder volume attached and mounted on kubelets host machine. More info: https://examples.k8s.io/mysql-cinder-pd/README.md

claimRef 🔗
ObjectReference

claimRef is part of a bi-directional binding between PersistentVolume and PersistentVolumeClaim. Expected to be non-nil when bound. claim.VolumeName is the authoritative bind between PV and PVC. More info: https://kubernetes.io/docs/concepts/storage/persistent-volumes#binding

csi 🔗
CSIPersistentVolumeSource

csi represents storage that is handled by an external CSI driver (Beta feature).

fc 🔗
FCVolumeSource

fc represents a Fibre Channel resource that is attached to a kubelet's host machine and then exposed to the pod.

flexVolume 🔗
FlexPersistentVolumeSource

flexVolume represents a generic volume resource that is provisioned/attached using an exec based plugin.

flocker 🔗
FlockerVolumeSource

flocker represents a Flocker volume attached to a kubelet's host machine and exposed to the pod for its usage. This depends on the Flocker control service being running

gcePersistentDisk 🔗
GCEPersistentDiskVolumeSource

gcePersistentDisk represents a GCE Disk resource that is attached to a kubelet's host machine and then exposed to the pod. Provisioned by an admin. More info: https://kubernetes.io/docs/concepts/storage/volumes#gcepersistentdisk

glusterfs 🔗
GlusterfsPersistentVolumeSource

glusterfs represents a Glusterfs volume that is attached to a host and exposed to the pod. Provisioned by an admin. More info: https://examples.k8s.io/volumes/glusterfs/README.md

hostPath 🔗
HostPathVolumeSource

hostPath represents a directory on the host. Provisioned by a developer or tester. This is useful for single-node development and testing only! On-host storage is not supported in any way and WILL NOT WORK in a multi-node cluster. More info: https://kubernetes.io/docs/concepts/storage/volumes#hostpath

iscsi 🔗
ISCSIPersistentVolumeSource

iscsi represents an ISCSI Disk resource that is attached to a kubelet's host machine and then exposed to the pod. Provisioned by an admin.

local 🔗
LocalVolumeSource

local represents directly-attached storage with node affinity

mountOptions
array

mountOptions is the list of mount options, e.g. ["ro", "soft"]. Not validated - mount will simply fail if one is invalid. More info: https://kubernetes.io/docs/concepts/storage/persistent-volumes/#mount-options

nfs 🔗
NFSVolumeSource

nfs represents an NFS mount on the host. Provisioned by an admin. More info: https://kubernetes.io/docs/concepts/storage/volumes#nfs

nodeAffinity 🔗
VolumeNodeAffinity

nodeAffinity defines constraints that limit what nodes this volume can be accessed from. This field influences the scheduling of pods that use this volume.

persistentVolumeReclaimPolicy
string

persistentVolumeReclaimPolicy defines what happens to a persistent volume when released from its claim. Valid options are Retain (default for manually created PersistentVolumes), Delete (default for dynamically provisioned PersistentVolumes), and Recycle (deprecated). Recycle must be supported by the volume plugin underlying this PersistentVolume. More info: https://kubernetes.io/docs/concepts/storage/persistent-volumes#reclaiming

photonPersistentDisk 🔗
PhotonPersistentDiskVolumeSource

photonPersistentDisk represents a PhotonController persistent disk attached and mounted on kubelets host machine

portworxVolume 🔗
PortworxVolumeSource

portworxVolume represents a portworx volume attached and mounted on kubelets host machine

quobyte 🔗
QuobyteVolumeSource

quobyte represents a Quobyte mount on the host that shares a pod's lifetime

rbd 🔗
RBDPersistentVolumeSource

rbd represents a Rados Block Device mount on the host that shares a pod's lifetime. More info: https://examples.k8s.io/volumes/rbd/README.md

scaleIO 🔗
ScaleIOPersistentVolumeSource

scaleIO represents a ScaleIO persistent volume attached and mounted on Kubernetes nodes.

storageClassName
string

storageClassName is the name of StorageClass to which this persistent volume belongs. Empty value means that this volume does not belong to any StorageClass.

storageos 🔗
StorageOSPersistentVolumeSource

storageOS represents a StorageOS volume that is attached to the kubelet's host machine and mounted into the pod More info: https://examples.k8s.io/volumes/storageos/README.md

volumeMode
string

volumeMode defines if a volume is intended to be used with a formatted filesystem or to remain in raw block state. Value of Filesystem is implied when not included in spec.

vsphereVolume 🔗
VsphereVirtualDiskVolumeSource

vsphereVolume represents a vSphere volume attached and mounted on kubelets host machine

See an issue here?